« PAD Project... 90 days really worked for me! | Main | Olympus Photo Safari Group : PAD Project »
Wednesday
Mar312010

Lightzone 3.9 released, E-P2/PL1 now supported.

Hello everyone,

great news! Light Crafts have released version 3.9 of Lightzone with native support for the Olympus E-P2 and E-PL1 added.

I suspect this will be the last point release before version 4.0... great to see the latest m4/3rds cameras being supported so quickly.

Remember, you get the chance to win a free copy of Lightzone every month, courtesy of the Lightzone contest we're hosting on mu-43.com (last chance today to make an entry for March!)

Cheers

Brian

PrintView Printer Friendly Version

EmailEmail Article to Friend

Reader Comments (1)

Hi Brian may I ask you just one question? Anyway here it goes..I just got myself an epl1 and I couldn't be any happier because of its excellent color rendition, sharpness and small size. But I just noticed that after a few shots the IS icon turns red (this means the stabilizer is disengaged when the internal temp reaches its limit -Page 50 on the Epl1 manual)
Did you ever experience this? I'm not sure if its normal or maybe because It's just so damn hot here in the Philippines nowadays( pardon the language hehe). Every time I use it the icon turns red immediately even after just say 5 shots if the IS is on. I'd be glad to hear your input on this thanks :)

best
Paul T

May 18, 2010 | Unregistered CommenterPaul Tanjuakio

PostPost a New Comment

Enter your information below to add a new comment.
Author Email (optional):
Author URL (optional):
Post:
 
Some HTML allowed: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <code> <em> <i> <strike> <strong>